The February 2026 release of AutoUpgrade (26.2) is available

This is a ground-breaking new release of AutoUpgrade, and the team worked hard to release it last weekend. This means for you that you should renew your AutoUpgrade tools as The February 2026 release of AutoUpgrade (26.2) is available now for download.

1..2..3..4..5..0 …

In case you wonder about this cryptic headline, no worries. a customer highlighted this well-chosen and easy-to-remember number to me the other day. And I was not aware, but it is true: KB123450 is the MOS note allowing you to download AutoUpgrade from MOS. Awesome … I already programmed this into my finger muscles without thinking for a second 🙂

And most of you know that you can also fetch it without login from oracle.com/goto/upgrade by clicking on the big black button or with a curl or wget directly.

 

Ground-breaking new features

When you check the change log, those awesome new features will jump into your eye.

  1. Let AutoUpgrade build your Gold Image using the Oracle Upgrade Advisor
  2. Use AutoUpgrade for an entirely RAC rolling patching operation in your RAC environment
  3. AutoUpgrade auto-updates itself

Before I list the entire feature and fix list, let me explain a bit more about those new features since this is the most important release of AutoUpgrade in more than 1 year. And we all really love those features – as you will for sure, too, soon!

  1. Gold Images from the Oracle Update Advisor service

    The Oracle Update Advisor (OUA) is not very well known yet. But it allows you to either download Gold Images (if they exist already) or – even better – have your own Gold Image custom-built. AutoUpgrade to my knowledge is the first tool which fully supports this for Oracle Database 19c and 26ai. And the benefit in 19c on the side is that it will then include the base release as well which otherwise you would need to download separately.

    Now, if you are going to try this out, this blog post by my team mate Rodrigo Jorge is an absolute MUST:
    https://www.dbarj.com.br/en/2026/02/downloading-and-using-gold-image-with-autoupgrade/

    In order to use this service, you need to pass on your CSI into AutoUpgrade’s SEPS (Secure External Password Store) where you already stored your MOS credential in it. As said about. Rodrigo Jorge shows you all the steps to try it out in Download And Using Gold Images with AutoUpgrade article.

    I am totally excited about this feature, and how AutoUpgrade makes it easy to use it. Regardless whether you download a prebuilt image, or your own customized gold image (which then obviously takes longer since we are going to build it for you individually).

    Since questions came up already, you don’t have to add your CSI. This is only needed when you want to download Gold Images. All other features work as before. What you may want to add to NOT use Gold Images, is the AU parameter gold_image=no since this defaults to AUTO.

  2. RAC Rolling Patching

    If the Gold Image build service wouldn’t be enough, there is more in the AutoUpgrade 26.2 version. It fully supports now RAC Rolling patching. In case you’d ask now: Didn’t you guys support RAC patching before? We did, indeed. But we were using the AutoUpgrade framework. And it simply did restart the database – exactly what you do not want to see when you patch “rolling”.

    And this is exactly what we support now with prefix.rac_rolling as a new parameter. AutoUpgrade is now able to patch your RAC databases completely rolling. Of course, you can also built your database homes with AutoUpgrade, too, But there is so much more. You can configure the prefix.drain_timeout and a lot more. I know, some of you are going to try this out right away, and Rodrigo has spent a lot of time the past days to release blog posts for the new features – truly a MUST READ:

    1. RAC Rolling Mode in AutoUpgrade
    2. How to patch the Oracle database using controlled RAC Rolling with AutoUpgrade
  3. AutoUpgrade auto-updates itself

    And finally, something we wished for already for some time. AutoUpgrade checks the version you are using to download the software and patches, and in case there is a newer AutoUpgrade version available, it simply updates itself. The only task you have is using the newest version then for all subsequent activities. There is nothing required to trigger this cool feature – it just does it for you.

Ah, before I forget, you can now download also the SDO (Spatial Patch Bundles) and the TEXT Bundles directly with just a keyword. A DBA’s life is getting so much more easier with AutoUpgrade. We all are super-proud on our Upgrade Development team.

 

Features, enhancements and fixes in 26.1 and 26.2

This is the list of features, checks, enhancements and fixes in the AutoUpgrade 26.1 and 26.2 versions.

New Features

AUPG-4157 RAC Rolling patching is now available in AutoUpgrade
AUPG-4908 AutoUpgrade Patching – Integrated with Oracle Patch Planner API to enable downloads of Oracle Gold Images
AUPG-4948 Automatically update the autoupgrade.jar file for customers based on their preference

New Checks

AUPG-5026 Check REPLAY_UPGRADE_SUPPORT Modify validation for replay upgrade was convert to a new check

Enhancements

AUPG-4710 AutoUpgrade Patching – Support new patch types of Spatial Bundle Patch (SDOBP) and Oracle Text (TEXT)
AUPG-4817 AutoUpgrade Patching – ROOTSH phase now creates a new JSON file rootsh.json in the rootsh directory containing an array of scripts to execute when manual execution of root scripts is required
AUPG-4953 Create a new JSON file patches_info.json with an overview of patches contained in the “patch” folder
AUPG-5041 Adjust number of concurrent PDB creations during a CLONEPDB phase
AUPG-5105 AutoUpgrade Patching – Guarantee that no internet access will happen when download=no
AUPG-5117 Allow 26 as alias for 23 in target_version
AUPG-5124 Check TARGET_HOME_REGISTERED_INVENTORY now verifies inventory information on remote nodes and ensure all remote nodes are attached to the target oracle home. The message was also improved to provide clarity.
AUPG-5147 Check PARAM_OBSOLETE now handles RAC instance specific parameters
AUPG-5152 Log full AutoUpgrade and Configuration Paths.
AUPG-5153 Add a separator into the log file for every new invocation of AutoUpgrade
AUPG-5177 Copy Datapatch log files into the DBUPGRADE directory
AUPG-5320 Create configuration option for datapatch_terminate_blocking_sessions to enable or disable the feature. This feature is set to on by default and can be turned off when value is set to NO.
AUPG-5415 AutoUpgrade Patching – Add Monthly Recommended Patches (MRP) support for 23,19.29
AUPG-5534 Configuration parameter datapatch_terminate_blocking_sessions is now set to disable this feature by default. The feature can be turned on when datapatch_terminate_blocking_sessions value is set to YES.

Change in behavior

AUPG-3702 AutoUpgrade will stop execution after performing the describe operation for Non-CDB to PDB scenarios when the parameter manage_standbys_clause=STANDBYS is set to any value other than NO, so that manual steps can be completed on the standby databases.
BUG-36840209 Increase parallel degree for plugin type of upgrades

Bugs

AUPG-3805 Distributed upgrades are running classical upgrade on the distributed nodes when prefix.replay=YES
AUPG-4830 Not Setting PLSQL_WARNINGS column value correctly in the v$parameter table
AUPG-5073 Error ORA-01565 appears in the alert log when removing the temporary SPFILE in the post upgrade stage for RAC
AUPG-5103 Validate config file is present during a restore
AUPG-5120 CDB$ROOT upgrade time is logged twice in upg_summary.log when using the RAC distributed PDB upgrade feature
AUPG-5121 Improve performance on the first batch of PDB upgrades
AUPG-5127 Make sure database is in upgrade mode when patching in upgrade mode
AUPG-5131 Check KEYSTORE_CONFLICT failed for same version Non-CDB to PDB
AUPG-5209 Ensure that a resume operation of a create pluggable database does not exist in the target CDB
AUPG-5216 Backport of AUPG-4985/BUG-38328301 SIHA AutoUpgrade restore fails from 26 TO 21 trying to get ASM information
AUPG-5232 AutoUpgrade Patching – Querying for the latest Oracle Clusterware (OCW) patch returns more than one result
AUPG-5236 19.28 TO 26 RAC database hangs during deploy phase with UPG-3105 error unable to start RAC database
AUPG-5238 AutoUpgrade Patching – Does not honor a redirect of the /tmp directory
AUPG-5295 Check TARGET_CDB_AVAILABILITY message suggests inaccurate action
AUPG-5300 Missing during_upgrade_pfile_catctl.ora on remote node causes ORA-01078 during CDB upgrade. The attempt to open the database is not necessary for distributed PDB upgrade scenarios, so it was removed.
AUPG-5307 AutoUpgrade Patching – Raise error when multiple RUs are listed in patch parameter
AUPG-5322 Windows service does not exist after successful upgrade with virtual accounts
AUPG-5541 AutoUpgrade Patching – ARU Query Issues: 19.30 is not detected due to a change in the description format.
BUG-36804851 Database hangs with message waiting for latch with size XXX. Additional diagnostic reporting was added to evaluate which check was hanging.
BUG-37308434 Instance attempts to mount shared but instance 1 has already mounted exclusive
BUG-38208051 PDB cannot perform a time zone upgrade when CDB root is opened in restricted mode. An ORA-65054 error is returned during AutoUpgrade processing.
BUG-38454035 Check PREVENT_EMPTY_DATAPATCH_DIRECTORY_ERROR cannot be run in parallel as copy operations report destination file already exists errors
BUG-38516923 AutoUpgrade sample configuration file produced wrong values for run_dictionary_health. Values changed from “yes,no” to “full,critical”
BUG-38594384 Ignore database startup error ORA-25138 string initialization parameter has been made obsolete
BUG-38708663 AutoUpgrade fails to create sample configuration file when inventory file is not present

REST API

None

 

Fix for the 19.30 download issue

In case you wonder about 26.2 instead of 26.1, the reason for the recut had to do indirectly with the recut of the 19.30 RU. When the 19.30 RU got re-released under 19.30 again but with a change (as you can read in more detail here), it also received an unusual name:

Patch 38632161: DATABASE RELEASE UPDATE 19.30.0.0.0(REL-JAN260130)

The part in the brackets broke AutoUpgrade’s mechanism to detect the correct patch. Those of you who explicitly wanted to download patch=RU:19.30 received an error, those who used patch=RECOMMENDED or patch=RU got 19.28 instead of 19.30 since 19.29 is password protected, and then AutoUpgrade fetches the newest available RU – which in this particular case with the known naming of RUs had been 19.28. The team worked hard to deliver an emergency fix on the weekend, and the 26.2 release of AutoUpgrade is able to download the RU 19.30 now without any further issues.

 

Further Links and Information

–Mike