JSON

Webinar: Converged databases and upgrade to Oracle Database 19c

Registration Link

Webinar: Converged databases and upgrade to Oracle Database 19c
22 April 2021, Thursday11:00 – 13:45 CET
Join us to meet our experts and tech specialists!
Register Now
We are pleased to invite you to the webinar where our experts will talk about the benefits of Oracle converged database and upgrade to Oracle Database 19c version.
For decades, the best global companies have relied on Oracle Database as an efficient tool for high performance, scalability, dependability, and operational and analytical database security. Fully compliant with convergence criteria, Oracle Database 19c will be the principal Oracle Database version in operation
Continue reading...

Solution for ORA-02303 from JSON_OBJECT_INVALID in upgrade to 19c

I just learned yesterday about this error – and as it seems to happen occasionally, you may want to read more about the Solution for ORA-02303 from JSON_OBJECT_INVALID in upgrade to 19c.

What happens?

You are upgrading a database to Oracle 19c, and you see this error pattern:

CREATE OR REPLACE TYPE JSON_Object_T AUTHID CURRENT_USER UNDER JSON_Element_T(
*
ERROR at line 1:
ORA-02303: cannot drop or replace a type with type or table dependents

This is coming when catjson.sql gets executed.

Why does it happen?

Unfortunately the FORCE option is missing when we create …

Continue reading...