In case you miss DBMS_OPTIM_BUNDLE … again …?!?

I’m tempted to copy and paste my blog post about DBMS_OPTIM_BUNDLE from February 2019, and exchange only 12.2.0.1 with 19c. But in this case the root cause is different. So this blog post is meant for Oracle 19.3.0 to be precise – in case you miss DBMS_OPTIM_BUNDLE … again … ?!? Information about DBMS_OPTIM_BUNDLE You will find a lot of information about DBMS_OPTIM_BUNDLE, what it does, since which release it exists and much more in these blog posts: In case you are missing DBMS_OPTIM_BUNDLE (Feb 11, 2019) DBMS_OPTIM_BUNDLE Package in Oracle 12.2 and 18c (Mar 8, 2019) DBMS_OPTIM_BUNDLE – only…

DBMS_OPTIM_BUNDLE Package in Oracle 12.2 and 18c

Yes, I did blog about the DBMS_OPTIM_BUNDLE package in earlier Oracle releases before. And I thought (and it was documented this way) that it will disappear in Oracle 12.2 and newer. But in fact you’ll find the DBMS_OPTIM_BUNDLE package in Oracle 12.2 and 18c. Most likely … This is a very interesting case and you may see also my previous blog posts: DBMS_OPTIM_BUNDLE – only available in Oracle 12.1.0.2 – or not? Fixes for Adaptive Features are included in Oracle 12.1.0.2 October 2017 BP Package Differences between Oracle 11.2.0.4 and 12.1.0.2? DBMS_OPTIM_BUNDLE Package in Oracle 12.2 and 18c First of…

DBMS_OPTIM_BUNDLE – only available in Oracle 12.1.0.2 – or not?

The DBMS_OPTIM_BUNDLE package got introduced with the April 2014 Exadata 11.2.0.4 Bundle Patch. And it got introduced for all Oracle 12.1.0.2 databases with the April 2017 Bundle Patch (BP). DBMS_OPTIM_BUNDLE is only available in Oracle 12.1.0.2. Addition March 6, 2018: See the updated blog post about DBMS_OPTIM_BUNDLE available in Oracle 12.2 and 18c onwards. https://mikedietrichde.com/2018/03/08/dbms_optim_bundle-package-oracle-12-2-18c/ For more information on this package on Exadata in Oracle 11.2.0.4 you may look at: MOS Note:1942966.1: Exadata: DBMS_OPTIM Package Philippe Fierens’ blog post from October 2014 Purpose of DBMS_OPTIM_BUNDLE package in Oracle 12.1.0.2 The package got introduced to enable module bug fixes which cause…