Flaws and Pitfalls

GI 19.31 and 19.32: trace file flooding in mgmtca.trc can happen

Thanks to Peter Lehmann who always alerts me about findings and encounters he had in his test and production RAC cluster environments. Peter dropped me an email the other day, and I share his suspicion that this may effect many in the coming weeks operating RAC environments. If you don’t have a RAC, you may not see this happening with GI 19.31 and 19.32: trace file flooding in mgmtca.trc can happen.

GI 19.31 and 19.32: trace file flooding in mgmtca.trc can happen

Photo by Giovanna Gomes on Unsplash

What happens?

It took me a bit of searching, and Peter collected a lot of information already.

Two months after patching GI …

Continue reading...

ORA-600 [] and ORA-8103 errors can happen after TTS Import into 19c

This is not a new finding – and it is a very rare error. But you may only find it days, months or even years after a TTS migration has been completed. You may see a rare corruption issue, and it may sleep in your database. The error pattern would be: ORA-600 [<objdchk>] and ORA-8103 errors can happen after TTS Import into 19c when you query certain data sets. A customer of ours has encountered this a two years after an xTTS migration in an archival database. And since my team works with a lot of large migrations, I think
Continue reading...

Upgrade to 26ai may hang due to block checking events

This issue is caused by an internal change, and we hit this now with two very large customer upgrades recently. Therefore, I would like to point to a fix, a workaround and the following RU in case you see your Upgrade to 26ai may hang due to block checking events.

Upgrade to 26ai may hang due to block checking events

Photo by Nareeta Martin on Unsplash

What would you see?

This issue can happen with cloning, PDB refreshable clones or just a copy or restore of your database for the subsequent upgrade to Oracle AI Database 26ai. It is not dependent on AutoUpgrade but since AutoUpgrade is the only …

Continue reading...

OJVM patching fails with ORA-1403 in 19.30 if JAVAVM is not installed

Thanks to all the people (Jeff, Daniele, Lothar and others) who alerted me about this topic. Some of you had even created their own fix already. So, this is about an issue which happens only if you have no JAVAVM installed in your database or PDB but you still apply the OJVM Bundle on to of the Oracle Database 19.30 Release Update. You may find then: OJVM patching fails with ORA-1403 in 19.30 if JAVAVM is not installed.

When does this happen?

This issue happens when you apply the OJVM bundle together with …

Continue reading...

What has happened to the 19.29 and 19.30 RUs?

Many of you mailed us asking why AutoUpgrade does not download 19.29 or 19.30 RUs anymore. Others just noticed that the RUs got pulled without further communication visible. And a few people informed me about an issue with the 19.30 RU when you don’t have OJVM configured but install the OJVM bundle. So, what has happened to the 19.29 and 19.30 RUs??

What has happened to the 19.29 and 19.30 RUs?

Photo by Lukas Seitz on Unsplash

Release Update 19.29 and 19.30

A fix for Bug 34352668 – LNX64-23.1-RAC: SVCB HIT ORA-600 [KCBGTCR_17] has been included into RUs 19.29 and 19.30 but unfortunately it could potentially cause a regression

Continue reading...

DBMS_OPTIM_BUNDLE and the standby database?

I could have sworn that I had blogged about it. Aleksey had a comment on the blog and I could not find the answer. But I knew that I had discussed this topic with several people in email already. Maybe it has fallen off my long list of future blog posts. No worries, here it is: DBMS_OPTIM_BUNDLE and the standby database?

DBMS_OPTIM_BUNDLE and the standby database?

Photo by 张 嘴 on Unsplash

DBMS_OPTIM_BUNDLE – short recap

I have a longer list of DBMS_OPTIM_BUNDLE blog posts, and you can easily navigate to them here. In very short, you will use the package to enable potentially …

Continue reading...

Small Pages not allowed for SGA from 19.27 and newer on Exadata

Having good friends in Oracle is key. And honestly one of the best things in my role. Philippe Fierens, product manager for Oracle’s Fleet Patching and Provisioning mailed me yesterday night sharing that there is an interesting change coming with Database Release Update 19.27: Small Pages not allowed for SGA from 19.27 and newer on Exadata.

What does this mean?

As you can read in MOS Note: 3081878.1 – Starting DBRU 19.27 Small Pages Are Not Allowed for RDBMS SGA In Exadata, from Release Update 19.27 onward (this is the April 2025 …

Continue reading...

ORA-12850 when you run AutoUpgrade?

Nicola made a comment the other day informing me that they hit an issue on some of their databases when upgrading. But is there a general issue with ORA-12850 when you run AutoUpgrade? Or is this error just the reflection of another issue? Let’s see, I will explain this and include a workaround as well.

What is the problem?

Nicola traced it down mostly already. During the upgrade of their CDBs, this error happened in some runs:

with segments as (select /*+ MATERIALIZE PARALLEL(2) */ tablespace_name, inuse from( select ds.tablespace_name, row_number() over (partition by 
Continue reading...

Queries on dictionary tables are slow in Oracle Multitenant?

I love to learn something new every day. And on Friday afternoon last week I learned something new again. It started (as often) with a very simple question from a colleague working from the Oracle Malaga office in Spain. The customer has an issues with some queries being slower than before once they moved from on-prem to the cloud into a PDB. But are queries on dictionary tables are slow in Oracle Multitenant generally?

What was the case?

The customer ran some queries against dictionary views in the PDB in Oracle Database …

Continue reading...

Voodoo with init parameters and Oracle Restart

Uwe Kirchhoff, one of the best techies I know in the entire Oracle CSS (formerly ACS) Support, mailed me before the Christmas holidays with a simple question. He discovered that altering init.ora parameters in a session does not necessarily write the parameter down into the spfile. Sounds a bit like Voodoo with init parameters,  and Oracle Restart has a role in this story as well. If you don’t have or do not plan to use Oracle Restart, then this is not interesting for you. But of course, you are free to still read it 🙂

Voodoo with init parameters and Oracle Restart

Photo by Marko Manojlovic on

Continue reading...

Datapatch may be slower when Traditional and Unified Auditing are on

I wrote several times especially about Unified Auditing in the past. It is a very efficient and useful way to audit operations in the database. But you need to be a bit careful about what’s on, and what isn’t. Now we recently had a customer case where it was clearly proven that Datapatch may be slower when Traditional and Unified Auditing are on. But how can this happen?

Recapping Traditional Auditing

At first, I am neither a security not an auditing expert. But I played quite a bit with Unified Auditing over the …

Continue reading...

Oracle Optimizer Statistics Advisor in Oracle 19c

Christian Pfundtner pointed me to the fact that my old blog post about the Statistics Advisor from 2017 may not be up to date anymore. And he further pointed out that some of his clients still suffer from issues with the tool. Hence, let me refresh the topic with Oracle Optimizer Statistics Advisor in Oracle 19c. And thanks to Christian for the pointers.

 

Overview

At first, I won’t rewrite the entire blog post but instead focus on recent findings. Therefore, you may please want to read my previous blog post about the …

Continue reading...

ORA-13516 “CATPROC not valid” during datapatch or autoupgrade to 19.18.0

I thought I could relax this week using my leftover vacation days from 2022. But this issue is triggering me since some of you mailed me already. Maybe this blog post can prevent others from being trapped by this issue: ORA-13516 “CATPROC not valid” during datapatch or autoupgrade to 19.18.0. And as a prolog, you will NOT see the below issue when you started your database in NORMAL mode for the execution of datapatch.

 

What is the symptom?

Regardless of whether you patch to Oracle Database RU 19.18.0 manually or with …

Continue reading...

Hide and Seek with RU 19.18.0

One and a half weeks ago we released the Database and Grid Infrastructure Release Updates (RU) 19.18.0. You could read on the blog how to apply it, and you could read also about an alert. So far, all was more or less transparent but apparently sort of an Hide and Seek with RU 19.18.0 has happened. So let me shed some light.

Heads Up!

I am just the messenger trying to bring some light into the topic. Neither is our team responsible nor do we have any sort of control on this process. I …

Continue reading...

Suppress nasty error messages and traces during datapatch

A few days ago I published my quarterly blog post in the series of Patching all my environments … And I mentioned that datapatch took a bit longer for 19.18.0 than usual. In the alert I’ve had nasty error messages or warnings. And Walter (thanks!) commented immediately with some advice.

 

What are these messages?

Actually, I saw them before already. Since I always create CUSTOM databases with a template I spotted those warnings the first time when I was wondering why DB creation took so abnormally long with Multitenant. I discovered KGL Heap …

Continue reading...

MRP3 for Oracle 19.17.0 adds an interesting surprise

You may have read my previous blog posts about MRPs (Monthly Recommended Patches). And today I did a quick check with Rodrigo. We both were a bit surprised to have the MRP3 for 19.17.0 add a lot of fixes to a standard RDBMS installation. So we were investigating a bit further. As a teaser, read on to see that MRP3 for Oracle 19.17.0 adds an interesting surprise.

 

How did we find out?

The MRP3 for Oracle Database 19.17.0 got released just a week ago. You can navigate to it via MOS

Continue reading...

Important alert for Oracle Database and GI RU 19.18.0 on Linux

Some of you may have seen the alert already released yesterday. And thanks to Peter Lehmann again for alerting me. When you logon to MyOracle Support, you will find it simply in the alert section to the left. On Jan 25, 2023, this Important alert for Oracle Database and GI RU 19.18.0 on Linux has been released.

Important alert for Oracle Database and GI RU 19.18.0 on Linux

Photo by Gary Bendig on Unsplash

 

What is the situation?

Due to an issue described in MOS Note: 2923428.1 – LMON trace file with repeated entries of “Submitting asynchronized dump request” the Release Updates (RU) 19.18.0 for the Oracle Database and …

Continue reading...

Rolling back or removing all patch SQL changes

This is quite an interesting case I’ve had to scratch my head at first as well. Magnus mailed me the other day asking for a client since the PDB compatibility check errored out with a patch conflict. We discussed the topic but the most easiest workaround to me was Rolling back or removing all patch SQL changes from the PDB before unplug. And since I had to look up the command I’d rather put it on the blog in case you or I need it again one day.

 

What is the case?

I …

Continue reading...

Upgrade from 11.2.0.4 to 19c with Label Security Policies

I remember, I have a blog. Forgive me that I don’t write a lot at the moment even though I still have a long queue of “future posts to write”. It is just too busy, and I was away for almost two full weeks in June as well. But let me briefly drop information on an issue I learned about recently. It just affects your when Upgrade from 11.2.0.4 to 19c with Label Security Policies. All other readers may simply ignore this blog post.

Upgrade from 11.2.0.4 to 19c with Label Security Policies

Photo by Erik Mclean on Unsplash

What happens?

You are using Oracle Label Security, and …

Continue reading...

Upgrading a PDB with JVM may result in ORA-7445 joevm_invokevirtual

As you know, this blog is also my brain dump about Oracle topics. Since this one happened yesterday, mostly at night with the help of my team mates and the Java team, I’d like to write it down into this blog post: Upgrading a PDB with Java may result in ORA-7445 joevm_invokevirtual() as it is still fresh and may affect you as well. If you don’t have PDBs, if you don’t have Java (or JVM) in it or if you upgraded already to Oracle Database 19c, you can stop reading now.

What

Continue reading...

Pitfall: Upgrade to 21c fails when ORDIM is present but no SDO

You may have read my previous blog post about Upgrading a non-CDB to Oracle Database 21c. And I referred to a potential Pitfall: Upgrade to 21c fails when ORDIM is present but no SDO. In this blog post I would like to explain how to avoid this pitfall beforehand and explain what needs to be done.

Pitfall: Upgrade to 21c fails when ORDIM is present but no SDO

Photo by Sara Codair on Unsplash

What’s the problem?

In my previous blog post I showed you the ideal and normal way. But during my tests I came across an issue I was not aware of – and I simply had no …

Continue reading...

DBMS_OPTIM_BUNDLE and Out-Of-Place Patching

Well, you see, this is most likely my special DBMS_OPTIM_BUNDLE week. And since I receive quite a number of questions, it may be good to discuss here about DBMS_OPTIM_BUNDLE and Out-Of-Place Patching?

DBMS_OPTIM_BUNDLE and Out-Of-Place Patching

Photo by Didssph on Unsplash

Out-of-place Patching

When you patch out-of-place with a new home – which is clearly our recommendation – you may see another tiny pitfall with DBMS_OPTIM_BUNDLE.

When you check DBA_DIRECTORIES, you will find two directories being related to DBMS_OPTIM_BUNDLE.

SQL> select directory_name, directory_path from dba_directories where directory_name like '%OPTIM%'

DIRECTORY_NAME	     DIRECTORY_PATH
-------------------- --------------------------------------------------
DBMS_OPTIM_LOGDIR    /u01/app/oracle/product/19/cfgtoollogs
DBMS_OPTIM_ADMINDIR  /u01/app/oracle/product/19/rdbms/admin

You see the “19” in the …

Continue reading...

After patching, Spatial Index creation fails with ORA-13249

Thanks again to Peter Lehmann from T-Systems for highlighting this issue to me. After patching, Spatial Index creation fails with ORA-13249. And Peter’s customer was quite worried. But see what may have caused this, and how we fixed it.

After patching, Spatial Index Creation Fails with ORA-13249

Photo by Bill Oxford on Unsplash

What happened?

Peter patched a system from 19.10.0 to 19.11.0. This database has undergone an upgrade from 12.2.0.1 to 19.7.0 before, then got patched to 19.9.0 before. The database has the Oracle Locator only but no Spatial installed. The patching including datapatch worked fine. All seemed to be good. Until the customer tried to …

Continue reading...

Messaging Gateway – Upgrade can’t find mgwu122.sql

Thanks to Christian Ballweg from Optiz Consulting who brought this issue to my attention. I haven’t seen it before since I haven’t installed it but you may encounter this if you have the Messaging Gateway – Upgrade can’t find mgwu122.sql.

What is the Messaging Gateway?

Actually I steal this from the documentation:

Messaging Gateway enables communication between applications based on non-Oracle messaging systems and Oracle Database Advanced Queuing.

Oracle Database Advanced Queuing provides propagation between two Oracle Database Advanced Queuing queues to enable e-business (HTTP through IDAP). Messaging Gateway extends

Continue reading...

Oracle 19c on Windows may flood your trace file directory

Oh … it’s Windows week here. And all this even though since I didn’t install Oracle on Windows for quite a while. But of course I’m fully aware that many of you out there operate Oracle on Windows. In this particular case thanks to Joël for the pointer to this issue. Oracle 19c on Windows may flood your trace file directory.

What happens?

In every release of Oracle 19c, at least until 19.10.0 BP, you may find out that every few minutes a trace file gets written into the %ORACLE_BASE%\diag\..\..\trace directory. And all …

Continue reading...