AIOUG OC Yatra 2025 is over, and I somehow recovered as well. As I wrote here, it was (again) an incredible experience with all those wonderful people (you!!) and those crazy speakers (us!) – and I learned a lot again. Still, I had no clue that Database and Developer evangelist and video wizard Connor McDonald would react to my friendly nagging 🙂

Photo by Graham Holtshausen on Unsplash
Have you used AutoUpgrade before?
If you say “No, not really“, then this video is for you. See how Connor dives into AutoUpgrade which he had never used before.
So, if Connor can do it, you can do it as well.
If you haven’t started with AutoUpgrade Patching yet, it’s time. It’s easy, it’s cool – and it really takes away all the nasty tasks you spend time on. Especially the search for the most recent bundles – ahhhh … and where’s OPatch???
AutoUpgrade does it all for you.
You want to get started?
Then this is your ideal starting point: Watch our Virtual Classroom Seminar – Episode 21: One-Button Patching.
Or, at least fetch the slides from here (Episode 21 – click on the picture).
It will take you not longer than Connor took in his video, and AutoUpgrade will download your patches and build your home – and patch your database. Try it out!!
See also Daniel’s various blog posts on AutoUpgrade Patching, for instance:
- AutoUpgrade Patching on Windows
- AutoUpgrade patches OCW in your database home
- Download patches for Grid Infrastructure
- Install an Oracle Home on a brand new server
and many many more.
The next time I’ll meet Connor, I will convince him on out-of-place patching on his laptop when AU hopefully is able to cleanup the remains of the old home 🙂
Thanks, Connor, for this awesome video!!
Further Links and Information
- AutoUpgrade – download the latest version directly
- Connor’s first steps with AutoUpgrade Patching
- Connor McDonald – Learning is not a spectator sport
- Youtube Channel: Connor McDonald
- Youtube Channel: UpgradeNow
- AIOUG OC Yatra 2025
–Mike
Hello Mike,
I noticed that today (22-10-2025, 8:00 CEST), the 19.29 patches are available on MOS, but when downloading it with Autoupgrade:
*Downloading Oracle Patch files
Query for the DPBP patch resulted in none being found
That is when using the ‘RECOMMENDED’ . So there seems to be a difference between what can be downloaded and what autoupgrade can find?
regards,
Paul
Hi Paul,
the message says that the Data Pump Bundle Patch isn’t available yet. AU tries to fetch the RU 19.29, then the OJVM 19.29, the matching OPatch and the Data Pump Bundle Patch 19.29.
I guess it had downloaded the RU, the OJVM and OPatch but not the DPBP.
Can you check this – or did it download nothing in this case?
Thanks,
Mike
Autoupgrade, the create_home phase, is failing on a RHEL8 with Oracle 19.29 as target home.
That was caused by the noexec of /tmp.
Would it be possible to add an alternative tmp dir somehow in the create_home phase ?
Cannot seem to find it in the documentation …
Hi Paul,
please give me more details, and add your config file, please.
Thanks
Mike
Hello Mike,
This is what we see. The tmp is noexec mounted:
[oracle@myhost autoupgrade]$ cat /etc/fstab|grep tmp
tmpfs /tmp tmpfs defaults,rw,nosuid,nodev,noexec,relatime,size=2G 0 0
tmpfs /dev/shm tmpfs defaults,nodev,size=16G 0 0
Then using this config:
[oracle@myhost autoupgrade]$ cat DB1929.cfg
global.global_log_dir=/home/oracle/autoupgrade/log
patch1.source_home=/opt/oracle/product/19.0.0/dbhome_1
patch1.target_home=/opt/oracle/product/19.0.0/dbhome_1929
patch1.sid=CDB01
patch1.folder=/u99/software/autoupg_patch
patch1.patch=RU:19.29,OPATCH,OJVM
patch1.download=NO
We create (attempt to) a new home:
[oracle@ip-10-110-108-152 autoupgrade]$ java -jar $ORACLE_HOME/rdbms/admin/autoupgrade.jar -version
build.version 25.6.251016
build.date 2025/10/16 00:04:36 +0000
build.hash 54a1e2442
build.hash_date 2025/10/15 21:11:40 +0000
build.supported_target_versions 12.2,18,19,21,23
build.type production
build.label (HEAD, tag: v25.6, origin/stable_devel, stable_devel)
build.MOS_NOTE 2485457.1
build.MOS_LINK https://support.oracle.com/epmos/faces/DocumentDisplay?id=2485457.1
[oracle@myhost autoupgrade]$ java -jar $ORACLE_HOME/rdbms/admin/autoupgrade.jar -config DB1929.cfg -patch -mode create_home
AutoUpgrade Patching 25.6.251016 launched with default internal options
Processing config file …
There were conditions found preventing AutoUpgrade Patching from successfully running
*The /tmp directory is mounted with “noexec” flag. This can prevent AutoUpgrade Patching from installing the Oracle software into the target home
And thus the create fails. Can we give an alternative tmp dir? How?
Hi Paul,
I will check with the team but I am pretty certain that hasn’t crossed our radar from anybody else yet.
Cheers,
Mike
Hi Mike,
Any update on this? We are getting the same error in creating a test 19.28 home. We are using the same autoupgrade.jar version.
Thanks.
Brian
Hi Brian,
please be more specific. Which error are you getting, which AU version, which config file.
Cheers,
Mike
Hi Mike,
The error was the same as Paul’s:
There were conditions found preventing AutoUpgrade Patching from successfully running
*The /tmp directory is mounted with “noexec” flag. This can prevent AutoUpgrade Patching from installing the Oracle software into the target home
AU version was 25.6.251016.
However, with AU version 26.2.260205, the error is now a very helpful:
There were conditions found preventing AutoUpgrade Patching from successfully running
*Validating that the tmp directory is not mounted with “noexec” flag
The /tmp directory is mounted with “noexec” flag. This can prevent AutoUpgrade Patching from installing the Oracle software into the target home. One way to fix this, without remounting the /tmp directory, is to set TMP or TMPDIR environmental variables to a path with the appropriate privileges using patch1.env=TMP= in the configuration file.
Setting “patch1.env=TMP=” fixes the problem, so thank you to the team for addressing this!
Thanks Brian – great summary!
Thanks
Mike
Hello Mike,
I am having problems downloading the 19.30 patches with autoupgrade.
Here is the message I get.
AutoUpgrade Patching 25.6.251016 launched with default internal options
Processing config file …
Loading AutoUpgrade Patching keystore
AutoUpgrade Patching keystore is loaded
Connected to MOS – Searching for specified patches
There were conditions found preventing AutoUpgrade Patching from successfully running
*Downloading Oracle Patch files
Cannot find the latest Release Update
Can you please help ?
Regards,
Lode
Hi Lode,
they’ve been pulled (19.29 and 19.30), and should hopefully appear soon again.
I will blog about it tomorrow – and this is the reason why AU does not find it, they are simply not there right now.
Thanks, and sorry for the inconvenience,
Mike
Hi Mike, does this tool do install base release everytime . if i have two home , will it not just apply patches with installing new home ?
Hi Vijay,
when you do out-of-place patching (which we do), then it will install the base release and patch it. This is how it works in 19c. In 26ai, this is going to be different since we’ll fetch a gold image which has “base release PLUS RU included”.
Cheers,
Mike
AutoUpgrade -mode create_home fails with UPG-1008 due to /var/tmp noexec despite setting TMP/TMPDIR.
Hi Mike,
We are running AutoUpgrade (26.3) for 19c patching/home provisioning (-mode create_home) on Oracle Linux 7/8 servers. In our enterprise environment, /var/tmp is mounted with the noexec flag due to strict corporate security compliance policies. To accommodate this, we created a dedicated directory /apps/oracle/tmp (which has full exec permissions) and set:
TMP and TMPDIR in oracle user’s ~/.bash_profile
patch1.env=TMP=/apps/oracle/tmp,TMPDIR=/apps/oracle/tmp in the AutoUpgrade config file
Java parameters -Djava.io.tmpdir=/apps/oracle/tmp
The Issue:
During execution of [ExecuteCreateOracleHome], AutoUpgrade stops with:
UPG-1008 [Unexpected exception error]
Cause: Failed to create target ORACLE_HOME.
*Validating that the tmp directory is not mounted with “noexec” flag
The /tmp directory is mounted with “noexec” flag.
Since remounting /var/tmp without noexec is strictly prohibited by our security policies, is there a specific parameter, hidden flag, or fix in AutoUpgrade to force all child/native processes to strictly honor the user-defined TMP directory?
Configuration File :
oracle@ind-lst-ora-ee-01 > cat autoupgrade_config_create_home_19.31_ind-lst-ora-ee-01.cfg
global.global_log_dir=/home/oracle/autoupgrade_logs_19_31_ind-lst-ora-ee-01_createhome
global.keystore=/IONDBA/ORARepository/keystore
patch1.target_version=19.0.0.0
patch1.target_base=/apps/oracle/server
patch1.source_home=/apps/oracle/server/19.28.0.0/dbhome_1
patch1.target_home=/apps/oracle/server/19.31.0.0/dbhome_1
patch1.folder=/IONDBA/ORARepository/patches_19_31/autoupgrade-patching/patches_19_31
patch1.sid=OLS19C01
patch1.restoration=no
patch1.patch=RU:19.31,OPATCH,DPBP
patch1.env=TMP=/apps/oracle/tmp
Hi Himanshu,
this isn’t actually an AutoUpgrade issue but most likely rather an runInstaller topic.
Try the following BEFORE calling AutoUpgrade with -create_home:
export TMP=/opt/oracle-tmp
export TMPDIR=/opt/oracle-tmp
(and of course, the directories you point to must exist and have exec privs).
Once you confirm, I can add this to a follow-up blog post for everyone.
Cheers,
Mike
Hi Mike,
Thank you for the quick response. Following up on your suggestion, I re-tested this cleanly on AutoUpgrade 26.3 and 26.4.260701, but unfortunately, the issue persists.
Before launching AutoUpgrade, we explicitly exported the following in the shell:
export TMP=/apps/oracle/tmp
export TMPDIR=/apps/oracle/tmp
export _JAVA_OPTIONS=”-Djava.io.tmpdir=/apps/oracle/tmp”
oracle@ind-lst-ora-ee-01 > cat /IONDBA/ORARepository/patches_19_31/autoupgrade-patching/autoupgrade_config_create_home_19.31_ind-lst-ora-ee-01.cfg
global.global_log_dir=/home/oracle/autoupgrade_logs_19_31_ind-lst-ora-ee-01_createhome
global.keystore=/IONDBA/ORARepository/keystore
patch1.target_version=19.0.0.0
patch1.target_base=/apps/oracle/server
patch1.source_home=/apps/oracle/server/19.28.0.0/dbhome_1
patch1.target_home=/apps/oracle/server/19.31.0.0/dbhome_1
patch1.folder=/IONDBA/ORARepository/patches_19_31/autoupgrade-patching/patches_19_31
patch1.sid=OLS19C01
patch1.restoration=no
patch1.patch=RU:19.31,OPATCH,DPBP
patch1.env=TMP=/apps/oracle/tmp,TMPDIR=/apps/oracle/tmp
oracle@ind-lst-ora-ee-01 >
oracle@ind-lst-ora-ee-01 >
oracle@ind-lst-ora-ee-01 > /apps/oracle/server/19.28.0.0/dbhome_1/jdk/bin/java -jar /apps/oracle/server/19.28.0.0/dbhome_1/rdbms/admin/autoupgrade.jar -config /IONDBA/ORARepository/patches_19_31/autoupgrade-patching/autoupgrade_config_create_home_19.31_ind-lst-ora-ee-01.cfg -mode create_home
AutoUpgrade 26.4.260701 launched with default internal options
Processing config file …
Loading AutoUpgrade keystore
AutoUpgrade keystore is loaded
+——————————–+
| Starting AutoUpgrade execution |
+——————————–+
Type ‘help’ to list console commands
upg>
————————————————-
Errors in database [OLS19C01]
Stage [CREATEORACLEHOME]
Operation [STOPPED]
Status [ERROR]
Info [
Error: UPG-1008
[Unexpected exception error]
Cause: Failed to create target ORACLE_HOME. For details, view the log file located at /home/oracle/autoupgrade_logs_19_31_ind-lst-ora-ee-01_createhome/OLS19C01/100/createhome/autopatch-jar.log
For further details, see the log file located at /home/oracle/autoupgrade_logs_19_31_ind-lst-ora-ee-01_createhome/OLS19C01/100/autoupgrade_20260804_user.log]
————————————————-
Logs: [/home/oracle/autoupgrade_logs_19_31_ind-lst-ora-ee-01_createhome/OLS19C01/100/autoupgrade_20260804_user.log]
————————————————-
upg> exit
There is 1 job in progress. if you exit it will stop
Are you sure you wish to leave? [y|N] y
——————- Final Summary ——————–
Number of databases [ 1 ]
Jobs finished [0]
Jobs failed [1]
Jobs restored [0]
Jobs pending [0]
——————– JOBS FAILED ———————
Job 100 for OLS19C01
Please check the summary report at:
/home/oracle/autoupgrade_logs_19_31_ind-lst-ora-ee-01_createhome/cfgtoollogs/upgrade/auto/status/status.html
/home/oracle/autoupgrade_logs_19_31_ind-lst-ora-ee-01_createhome/cfgtoollogs/upgrade/auto/status/status.log
Create a zip file of log files by using the following command. Zipped up log files are required for filing a service request.
java -jar autoupgrade.jar -config /IONDBA/ORARepository/patches_19_31/autoupgrade-patching/autoupgrade_config_create_home_19.31_ind-lst-ora-ee-01.cfg -zip
Exiting
oracle@ind-lst-ora-ee-01 > echo $TMP
/apps/oracle/tmp
oracle@ind-lst-ora-ee-01 > echo $TMPDIR
/apps/oracle/tmp
Here are the mount options on our server:
Notice that while system /tmp is mounted WITH execution permissions, /var/tmp is mounted with “noexec” for security compliance.
[root@ind-lst-ora-ee-01 ~]# ls -ld /tmp /var/tmp
drwxrwxrwt. 12 root root 360 Aug 4 07:53 /tmp
drwxrwxrwt. 997 root root 65536 Jul 29 16:35 /var/tmp
[root@ind-lst-ora-ee-01 ~]# findmnt -T /tmp && findmnt -T /var/tmp
TARGET SOURCE FSTYPE OPTIONS
/tmp tmpfs tmpfs rw,nosuid,nodev,seclabel
TARGET SOURCE FSTYPE OPTIONS
/var/tmp /dev/sda10 xfs rw,nosuid,nodev,noexec,relatime,seclabel,attr2,inode64,logbufs=8,logbsize=32k,noquota
Key Observation:
Even though TMP/TMPDIR/patch1.env point to /apps/oracle/tmp (which allows execution) and system /tmp allows execution, the underlying validation check in autopatch.jar appears to specifically inspect /var/tmp (which has noexec) and fails the CREATEORACLEHOME stage.
Since /var/tmp noexec is enforced by our enterprise security team, is there a way to prevent the autopatch check from inspecting /var/tmp when custom TMP/TMPDIR paths are provided?
Hi Himanshu,
are you running AU as root??
I am just wondering about because of:
[root@ind-lst-ora-ee-01 ~]# ls -ld /tmp /var/tmp
But you may have pasted this just to show me the mount points.
Can you open an SR please, and upload the entire log directory collected with
java -jar autoupgrade.jar -config yourconfig -zip
and send me the SR number?
Thanks
Mike
Hi Mike,
Thanks for taking a look!
Just to clarify, AutoUpgrade was executed strictly as the ‘oracle’ software owner user. The root prompt snippet was only used to run ‘findmnt’ and ‘ls -ld’ to display the OS mount point permissions.
Also, I already have an open SR for this issue and have generated and uploaded the complete updated ‘-zip’ diagnostics package to the SR as requested.
SR Number: AutoUpgrade Patching tool (version 26.3.260401) fails during ‘-mode create_home’ stage with UPG-1008 “4-0003376581”
HI Himanshu,
can you please use the newest AU tool, 26.5?
wget https://download.oracle.com/otn-pub/otn_software/autoupgrade.jar
And I saw a discussion internally with the team already. Support has started this conversation.
Thanks
Mike
Hello Mike say I have done one patching cycle from home_1 to home_2 using autoupgrade.
both homes have oracle software running. If on the next cycle I want to patch the home_1 ie move from home_2 to home_1, what command can I use to do this. In the -patch options for autoupgrade there is only a create_home and a deploy. no patch_home per say. How can I simply update and existing oracle home or do I have to drop all the contents of the existing old home and update it. please advise. Thanks, Harris
You can’t patch into an existing home.
You must clean out your home_1 after switching to home_2, then install the next incrarnation of the software into home_1, then switch from home_2 to home_1 (now with new software in place) etc etc.
Cheers,
Mike